diff configure.ac @ 34:b76a8da75ec3

* Check for SDL_mixer and SDL_gfx
author thib
date Sun, 08 Mar 2009 18:06:52 +0000
parents f45da03ca631
children f88d47a4bf87
line wrap: on
line diff
--- a/configure.ac
+++ b/configure.ac
@@ -97,6 +97,13 @@ AM_PATH_SDL()
 AC_SUBST(SDL_CFLAGS)
 AC_SUBST(SDL_LIBS)
 
+dnl check for sdl_gfx and sdl_mixer
+
+AC_CHECK_LIB(SDL_gfx, rotozoomSurfaceXY,,
+	AC_MSG_ERROR(This program cannot be build without SDL_gfx))
+AC_CHECK_LIB(SDL_mixer, Mix_OpenAudio,,
+	AC_MSG_ERROR(This program cannot be build without SDL_mixer))
+
 dnl SMPEG & MAD config
 AM_PATH_SMPEG()
 AC_SUBST(SMPEG_CFLAGS)