diff Cargo.toml @ 757:21b186be2590

Split the Rust version into multiple crates.
author Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
date Tue, 05 Jan 2021 02:16:32 +0100
parents fc937d93a57c
children f6c287745a67
line wrap: on
line diff
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,20 +1,14 @@
-[package]
-name = "touhou"
-version = "0.1.0"
-authors = ["Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>"]
-edition = "2018"
-description = "A collection of tools to work with Touhou data"
-homepage = "https://pytouhou.linkmauve.fr"
-license = "GPL-3.0-or-later"
+[workspace]
 
-# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+members = [
+    "formats",
+    "interpreters",
+    "runners",
+    "utils",
+]
 
-[dependencies]
-nom = { version = "6", default-features = false, features = ["alloc"] }
-encoding_rs = "0.8"
-image = { version = "0.23", default-features = false, features = ["png", "jpeg"] }
-bitflags = "1"
-luminance = "0.39"
-luminance-glfw = { version = "0.12", default-features = false, features = ["log-errors"] }
-luminance-derive = "0.5"
-ears = "0.8"
+[patch.crates-io]
+touhou-formats = { path = "formats" }
+touhou-interpreters = { path = "interpreters" }
+touhou-runners = { path = "runners" }
+touhou-utils = { path = "utils" }