diff setup.py @ 525:43ecf0f98f4d

Precalculate the inverse of the texture size at ANM load, to not recalculate at every sprite change.
author Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
date Wed, 18 Dec 2013 18:15:45 +0100
parents e8496e5ba056
children 7c3c90468996
line wrap: on
line diff
--- a/setup.py
+++ b/setup.py
@@ -72,7 +72,7 @@ except OSError:
 for directory, _, files in os.walk('pytouhou'):
     package = directory.replace(os.path.sep, '.')
     packages.append(package)
-    if package not in ('pytouhou.game', 'pytouhou.lib', 'pytouhou.utils') and not package.startswith('pytouhou.ui'):
+    if package not in ('pytouhou.formats', 'pytouhou.game', 'pytouhou.lib', 'pytouhou.utils') and not package.startswith('pytouhou.ui'):
         continue
     if package == 'pytouhou.ui' or package == 'pytouhou.ui.sdl':
         package_args = sdl_args
@@ -91,6 +91,8 @@ for directory, _, files in os.walk('pyto
                 compile_args = opengl_args
             elif extension_name == 'pytouhou.ui.anmrenderer' and not anmviewer:
                 continue
+            elif package == 'pytouhou.formats' and extension_name != 'pytouhou.formats.anm0':
+                continue
             else:
                 compile_args = package_args
             extensions.append(Extension(extension_name,