diff setup.py @ 455:6864a38b2413

Make pytouhou.lib.sdl cimportable, and convert pytouhou.ui.window.* to extension types.
author Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
date Mon, 02 Sep 2013 22:16:38 +0200
parents c034570ac785
children cae1ae9de430
line wrap: on
line diff
--- a/setup.py
+++ b/setup.py
@@ -45,8 +45,8 @@ for directory, _, files in os.walk('pyto
                 compile_args = get_arguments('--cflags', SDL_LIBRARIES)
                 link_args = get_arguments('--libs', SDL_LIBRARIES)
             elif extension_name.startswith('pytouhou.ui.'): #XXX
-                compile_args = get_arguments('--cflags', ['gl'])
-                link_args = get_arguments('--libs', ['gl'])
+                compile_args = get_arguments('--cflags', ['gl'] + SDL_LIBRARIES)
+                link_args = get_arguments('--libs', ['gl'] + SDL_LIBRARIES)
             else:
                 compile_args = None
                 link_args = None