diff setup.py @ 423:d8630c086926

Replace Pyglet with our own Cython OpenGL wrapper.
author Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
date Tue, 16 Jul 2013 21:07:15 +0200
parents b1248bab2d0f
children 77c0e9a53795
line wrap: on
line diff
--- a/setup.py
+++ b/setup.py
@@ -54,6 +54,9 @@ for directory, _, files in os.walk('pyto
             if extension_name == 'pytouhou.lib.sdl':
                 compile_args = check_output([COMMAND, '--cflags'] + LIBRARIES).split()
                 link_args = check_output([COMMAND, '--libs'] + LIBRARIES).split()
+            elif extension_name.startswith('pytouhou.ui.'): #XXX
+                compile_args = check_output([COMMAND, '--cflags', 'gl']).split()
+                link_args = check_output([COMMAND, '--libs', 'gl']).split()
             else:
                 compile_args = None
                 link_args = None