diff setup.py @ 590:e15672733c93

Switch to Python 3.x instead of 2.7.
author Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
date Tue, 30 Sep 2014 17:14:24 +0200
parents 8a8c2e519637
children 9dbc234ea087
line wrap: on
line diff
--- a/setup.py
+++ b/setup.py
@@ -76,7 +76,7 @@ default_libs = {
 
 def get_arguments(arg, libraries):
     try:
-        return check_output([COMMAND, arg] + libraries).split()
+        return check_output([COMMAND, arg] + libraries).decode().split()
     except CalledProcessError:
         # The error has already been displayed, just exit.
         sys.exit(1)
@@ -96,6 +96,8 @@ if use_opengl:
 
 
 for directory, _, files in os.walk('pytouhou'):
+    if directory.endswith('/__pycache__'):
+        continue
     package = directory.replace(os.path.sep, '.')
     if not use_opengl and package in ('pytouhou.ui.opengl', 'pytouhou.ui.opengl.shaders'):
         continue