diff runners/Cargo.toml @ 757:21b186be2590

Split the Rust version into multiple crates.
author Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
date Tue, 05 Jan 2021 02:16:32 +0100
parents Cargo.toml@fc937d93a57c
children dbe2ddca4a8b
line wrap: on
line diff
copy from Cargo.toml
copy to runners/Cargo.toml
--- a/Cargo.toml
+++ b/runners/Cargo.toml
@@ -1,19 +1,19 @@
 [package]
-name = "touhou"
+name = "touhou-runners"
 version = "0.1.0"
 authors = ["Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>"]
 edition = "2018"
-description = "A collection of tools to work with Touhou data"
+description = "Runners for Touhou games"
 homepage = "https://pytouhou.linkmauve.fr"
 license = "GPL-3.0-or-later"
 
 # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
 
 [dependencies]
-nom = { version = "6", default-features = false, features = ["alloc"] }
-encoding_rs = "0.8"
+touhou-formats = "*"
+touhou-interpreters = "*"
+touhou-utils = "*"
 image = { version = "0.23", default-features = false, features = ["png", "jpeg"] }
-bitflags = "1"
 luminance = "0.39"
 luminance-glfw = { version = "0.12", default-features = false, features = ["log-errors"] }
 luminance-derive = "0.5"