diff python/Cargo.toml @ 772:7492d384d122 default tip

Rust: Add a Glide renderer (2D only for now) This is an experiment for a Rust renderer, iterating over the Python data using pyo3. It requires --feature=glide to be passed to cargo build, doesn’t support NPOT textures, text rendering, the background, or even msg faces, some of that may come in a future changeset.
author Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
date Mon, 05 Sep 2022 17:53:36 +0200
parents f6c287745a67
children
line wrap: on
line diff
--- a/python/Cargo.toml
+++ b/python/Cargo.toml
@@ -15,3 +15,8 @@ name = "touhou"
 [dependencies]
 touhou-formats = "*"
 pyo3 = "0.17"
+image = { version = "0.24", default-features = false, features = ["png"], optional = true }
+
+[features]
+default = []
+glide = ["image"]